What mobile devices do you support?

If you are not using any of the OS versions or devices listed below, you may experience issues using our Apps.

Android

  • OS - Kit Kat (4.4 - 4.4.4), Lollipop (5.0-5.1.1), Marshmallow (6.0 - 6.0.1), Nougat (7.0 - 7.1.1).
  • Devices - We do our best to support devices released within the last 2-3 years.
  • As a rule of thumb, the newer the device, the better our apps will function.

iPhone

  • iOS 9 & 10 and up
  • Devices - iPhone 4, 4S, 5, 5C, 5S, 6, 6+, 7, 7+ 
  • As a rule of thumb, the newer the device, the better our apps will function.

iPod

  • 4th Generation or higher

 iPad/Tablets

  • iPads/Tablets released within the last 2-3 years that include the iTunes and/or the Google Play store. 
Was this article helpful?
2 out of 5 found this helpful